KLF 220 CDI unit replacement

Anything related to kawasaki.

Moderators: James - Admin, Mick- Can Am

KLF 220 CDI unit replacement

Postby Nwr161282 » Wed Feb 22, 2017 2:33 pm

Ok so after lots of testing it turns out my CDI box is faulty. I'm only getting a resistance reading between the red and the black and white wire (resistance reads 0 as it should). There is no resistance between the rest of the wires. So I'm guessing this is why I'm not getting any spark.

After a bit or research I found some people had fitted an intermotor 15210 ignition unit. So after a quick phone call to my local factors they had one in stock at less than £15 so thought I had nothing to loose so I gave it a try. I now get spark but sadly bike won't start. So I'm wondering if the intermotor unit is not producing the spark at the correct time. As I do get the odd pop and bang when trying to start.

Has anyone fitted a Chinese cdi to there quad and got it to work successfully if so which unit did you buy? And how is it wired.

Has anyone fitter the intermotor 15210 part and got it working. How is it wired?

Many thanks

Neil
Nwr161282
less than 20 posts
less than 20 posts
 
Posts: 3
Joined: Wed Feb 22, 2017 2:22 pm
Has thanked: 0 time
Been thanked: 0 time
Cash on hand: 70.00
Town/City: Aberdeenshire
Make. Enter none if you don't have one.: Kawasaki
Model: KLF 220 Bayou
Year of manufacture Enter 0 if none: 88

Share On:

Share on Twitter Twitter Share on MySpace MySpace

  • Advertisement

Return to Kawasaki

Who is online

Users browsing this forum: No registered users and 2 guests